12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485 |
- # Copyright 1999-2023 Gentoo Authors
- # Distributed under the terms of the GNU General Public License v2
- EAPI=8
- inherit autotools flag-o-matic
- DESCRIPTION="Terminal multiplexer"
- HOMEPAGE="https://tmux.github.io/"
- if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- SRC_URI="https://raw.githubusercontent.com/przepompownia/tmux-bash-completion/678a27616b70c649c6701cae9cd8c92b58cc051b/completions/tmux -> tmux-bash-completion-678a27616b70c649c6701cae9cd8c92b58cc051b"
- EGIT_REPO_URI="https://github.com/tmux/tmux.git"
- else
- SRC_URI="https://github.com/tmux/tmux/releases/download/${PV}/${P/_/-}.tar.gz"
- if [[ ${PV} != *_rc* ]] ; then
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
- fi
- S="${WORKDIR}/${P/_/-}"
- fi
- LICENSE="ISC"
- SLOT="0"
- IUSE="debug selinux systemd utempter vim-syntax"
- # See https://github.com/tmux/tmux/issues/3531 for minimum ncurses version
- DEPEND="
- dev-libs/libevent:=
- >=sys-libs/ncurses-6.4_p20230424:=
- systemd? ( sys-apps/systemd:= )
- utempter? ( sys-libs/libutempter )
- kernel_Darwin? ( dev-libs/libutf8proc:= )
- "
- BDEPEND="
- virtual/pkgconfig
- app-alternatives/yacc
- "
- RDEPEND="
- ${DEPEND}
- selinux? ( sec-policy/selinux-screen )
- vim-syntax? ( app-vim/vim-tmux )
- "
- DOCS=( CHANGES README )
- PATCHES=(
- "${FILESDIR}"/${PN}-2.4-flags.patch
- )
- src_prepare() {
- # bug 438558
- # 1.7 segfaults when entering copy mode if compiled with -Os
- replace-flags -Os -O2
- default
- eautoreconf
- }
- src_configure() {
- local myeconfargs=(
- --sysconfdir="${EPREFIX}"/etc
- $(use_enable debug)
- $(use_enable systemd)
- $(use_enable utempter)
- # For now, we only expose this for macOS, because
- # upstream strongly encourage it. I'm not sure it's
- # needed on Linux right now.
- $(use_enable kernel_Darwin utf8proc)
- )
- econf "${myeconfargs[@]}"
- }
- src_install() {
- default
- einstalldocs
- dodoc example_tmux.conf
- docompress -x /usr/share/doc/${PF}/example_tmux.conf
- }
|