PKGBUILD 580 B

12345678910111213141516171819202122232425262728
  1. # Maintainer: Alexander Rosenberg <zanderpkg at pm dot me>
  2. _pkgname='nvramtool'
  3. pkgname=$_pkgname-git
  4. pkgver=4.20.77.ga398b31108
  5. pkgrel=1
  6. pkgdesc='Coreboot cli utility for modifying NVRAM'
  7. url='https://coreboot.org'
  8. arch=('x86_64')
  9. license=('GPL2')
  10. provides=('nvramtool')
  11. makedepends=('git')
  12. source=('git+https://github.com/coreboot/coreboot.git')
  13. sha256sums=('SKIP')
  14. pkgver(){
  15. cd "coreboot"
  16. git describe --tags --long | sed 's#-#.#g'
  17. }
  18. build() {
  19. make -C 'coreboot/util/nvramtool'
  20. }
  21. package() {
  22. install -Dt "$pkgdir/usr/bin/" "coreboot/util/nvramtool/nvramtool"
  23. }