rules 2.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384
  1. #!/usr/bin/make -f
  2. # Made with the aid of dh_make, by Craig Small
  3. # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
  4. # Some lines taken from debmake, by Christoph Lameter.
  5. # $Id: rules,v 1.2 1999/01/18 02:38:15 jgg Exp $
  6. # Uncomment this to turn on verbose mode.
  7. #export DH_VERBOSE=1
  8. export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
  9. export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
  10. # FOR AUTOCONF 2.13 ONLY
  11. ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
  12. # confflags += --host=$(DEB_HOST_GNU_TYPE)
  13. else
  14. $(error Cannot cross-compile this package out-of-the-box)
  15. endif
  16. build: build-stamp
  17. build-stamp: configure
  18. dh_testdir
  19. -mkdir build
  20. cd build; ../configure
  21. cd ..
  22. # Add here commands to compile the package.
  23. make
  24. touch build-stamp
  25. clean:
  26. dh_testdir
  27. # dh_testroot
  28. rm -f build-stamp
  29. rm -rf build
  30. # Add here commands to clean up after the build process.
  31. -$(MAKE) clean
  32. -$(MAKE) distclean
  33. dh_clean
  34. # Build architecture-independent files here.
  35. binary-indep: build
  36. # We have nothing to do by default.
  37. # Build architecture-dependent files here.
  38. binary-arch: build dsync
  39. dsync: build
  40. # dh_testversion -pdsync
  41. dh_testdir -pdsync
  42. dh_testroot -pdsync
  43. dh_clean -pdsync -k
  44. dh_installdirs -pdsync usr/bin usr/doc/dsync usr/lib usr/doc/dsync
  45. cp build/bin/dsync-* debian/dsync/usr/bin/
  46. cp -a build/bin/libdsync.so.0.0.0 debian/dsync/usr/lib/
  47. cp -a build/bin/libdsync.so.0.0 debian/dsync/usr/lib/
  48. cp COPYING debian/dsync/usr/doc/dsync/copyright
  49. dh_installdocs -pdsync
  50. dh_installman -pdsync
  51. dh_installchangelogs -pdsync
  52. dh_strip -pdsync
  53. dh_compress -pdsync
  54. dh_fixperms -pdsync
  55. dh_installdeb -pdsync
  56. dh_makeshlibs -pdsync
  57. dh_shlibdeps -pdsync
  58. dh_gencontrol -pdsync
  59. dh_md5sums -pdsync
  60. dh_builddeb -pdsync
  61. source diff:
  62. @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
  63. configure:
  64. make startup
  65. binary: binary-indep binary-arch
  66. .PHONY: build clean binary-indep binary-arch binary