psensor-1.1.5.ebuild 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. # Copyright 1999-2018 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit gnome2-utils
  5. DESCRIPTION="Psensor is a graphical hardware monitoring application for Linux."
  6. SRC_URI="https://wpitchoune.net/psensor/files/${P}.tar.gz"
  7. SLOT=0
  8. IUSE="man doc appindicator libnotify atasmart server X"
  9. KEYWORD=""
  10. RDEPEND="sys-apps/lm_sensors
  11. x11-libs/gtk+:3
  12. libnotify? ( x11-libs/libnotify )
  13. appindicator? ( dev-libs/libappindicator )
  14. dev-libs/json-c
  15. sys-apps/lm_sensors:0/4.0.0
  16. gnome-base/libgtop:2
  17. atasmart? ( dev-libs/libatasmart )
  18. server? ( net-libs/libmicrohttpd )
  19. "
  20. DEPEND=$RDEPEND"man? ( sys-apps/help2man )
  21. doc? ( dev-ruby/asciidoctor )"
  22. src_configure() {
  23. econf \
  24. $(use_with X x)
  25. }
  26. pkg_preinst() {
  27. gnome2_icon_savelist
  28. gnome2_schemas_savelist
  29. }
  30. pkg_postinst() {
  31. fdo-mime_desktop_database_update
  32. gnome2_icon_cache_update
  33. gnome2_schemas_update
  34. }
  35. pkg_postrm() {
  36. fdo-mime_desktop_database_update
  37. gnome2_icon_cache_update
  38. gnome2_schemas_update
  39. }