cpupower-gui-0.6.2.ebuild 718 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Distributed under the terms of the GNU General Public License v2
  2. EAPI=7
  3. inherit autotools
  4. DESCRIPTION="Simple GUI for cpupower"
  5. HOMEPAGE="https://github.com/vagnum08/cpupower-gui/"
  6. SRC_URI="https://github.com/vagnum08/cpupower-gui/archive/v${PV}.zip -> ${P}.zip"
  7. LICENSE="GPL-3"
  8. SLOT="0"
  9. KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
  10. IUSE="nls"
  11. RDEPEND=">=x11-libs/gtk+-3.0
  12. sys-apps/dbus
  13. >=dev-lang/python-3
  14. sys-auth/polkit
  15. dev-python/dbus-python
  16. nls? ( sys-devel/gettext )"
  17. DEPEND="${RDEPEND}"
  18. S=${WORKDIR}/${PN}-${PV}
  19. src_prepare() {
  20. default
  21. eautoreconf
  22. }
  23. src_configure() {
  24. econf --disable-silent-rules $(use_enable nls)
  25. }
  26. src_install() {
  27. emake DESTDIR="${D}" install
  28. }