barrier-2.1.2.ebuild 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758
  1. # Copyright 1999-2018 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit eutils cmake-utils flag-o-matic
  5. DESCRIPTION="Lets you easily share a single mouse and keyboard between multiple computers"
  6. HOMEPAGE="https://github.com/debauchee/barrier"
  7. SRC_URI="https://github.com/debauchee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. IUSE="libressl qt5"
  12. RESTRICT="test"
  13. DEPEND="
  14. !libressl? ( dev-libs/openssl:* )
  15. libressl? ( dev-libs/libressl )
  16. net-misc/curl
  17. x11-libs/libICE
  18. x11-libs/libSM
  19. x11-libs/libX11
  20. x11-libs/libXext
  21. x11-libs/libXi
  22. x11-libs/libXinerama
  23. x11-libs/libXrandr
  24. x11-libs/libXtst
  25. qt5? (
  26. dev-qt/qtcore:5
  27. dev-qt/qtgui:5
  28. dev-qt/qtwidgets:5
  29. dev-qt/qtnetwork:5
  30. net-dns/avahi[mdnsresponder-compat]
  31. )
  32. x11-base/xorg-proto
  33. "
  34. RDEPEND="${DEPEND}"
  35. #PATCHES=( "${FILESDIR}"/${PN}-qt5.11-port.patch )
  36. src_configure() {
  37. local mycmakeargs=(
  38. -DBARRIER_BUILD_INSTALLER=OFF
  39. -DBARRIER_BUILD_GUI=$(usex qt5)
  40. )
  41. cmake-utils_src_configure
  42. }
  43. src_install() {
  44. cmake-utils_src_install
  45. if use qt5; then
  46. newicon -s 256 "${S}"/res/${PN}.png ${PN}.png
  47. newmenu "${S}"/res/${PN}.desktop ${PN}.desktop
  48. fi
  49. }