soundux-9999.ebuild 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758
  1. # Copyright 1999-2018 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit eutils cmake-utils git-r3 desktop
  5. DESCRIPTION="A cross-platform soundboard loud_sound"
  6. HOMEPAGE="https://soundux.rocks/"
  7. EGIT_REPO_URI="https://github.com/Soundux/Soundux.git"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS=
  11. IUSE=""
  12. RESTRICT="test"
  13. DEPEND="
  14. x11-libs/libX11
  15. x11-libs/libXi
  16. x11-base/xorg-proto
  17. net-libs/webkit-gtk
  18. "
  19. RDEPEND="${DEPEND}"
  20. src_install() {
  21. #emake DESTDIR="${D}" install
  22. insopts -m644
  23. newicon "${S}/assets/icon.png" "soundux.png"
  24. domenu "${FILESDIR}/soundux.desktop"
  25. mkdir -p "${D}/opt/${PN}/dist"
  26. insinto "/opt/${PN}/"
  27. into "/opt/${PN}/"
  28. #This application actually expects to be next to its dist folder.. so we install everything manually in /opt and make a symlik to the binary in /usr/bin. Like this it works fine.
  29. exeinto "/opt/${PN}/"
  30. dostrip "${WORKDIR}/${P}_build/soundux"
  31. doexe "${WORKDIR}/${P}_build/soundux"
  32. dosym "/opt/${PN}/${PN}" "/usr/bin/${PN}"
  33. doins -r "${S}/build/dist/"
  34. }
  35. pkg_postinst() {
  36. xdg_desktop_database_update
  37. }
  38. pkg_postrm() {
  39. xdg_desktop_database_update
  40. }